iCalendar
.ics , .ifb , .iCal , .iFBf , .icalendar
text/calendar
сериализация календаря
iCalendar (также сокращенно iCal ) — это формат данных, обсуждаемый и предлагаемый RFC 5545 (и последующими версиями) для обмена данными календаря. Он особенно используется для совместного использования календаря подписки через протоколы CalDAV и Web Calendar Access Protocol .
iCalendar позволяет пользователям отправлять запросы на прием и пересылать их другим пользователям по электронной почте . Получатели электронной почты, у которых есть программное обеспечение, поддерживающее формат iCalendar, могут легко ответить отправителю или предложить другую дату / время для встречи.
Он реализован / поддерживается большим количеством программного обеспечения, например iCal от Apple , Chandler , Lotus Notes , Zimbra , ScheduleWorld , SOGo , KOrganizer , Mozilla Lightning , Evolution , Windows Calendar и через расширение Microsoft Outlook . Интернет-приложение Google Calendar также использует этот стандарт. Виджеты, используемые в настраиваемых порталах, таких как Netvibes или Posh (согласно GNU GPL 3), также могут поддерживать этот формат.
Обмен данными ICalendar обычно осуществляется с использованием традиционной электронной почты, но предлагаемый стандарт был разработан так, чтобы не зависеть от транспортного протокола. Например, он также может быть опубликован и отредактирован с помощью сервера WebDAV . Упрощенные веб-серверы (предлагающие только протокол HTTP) часто используются для распространения данных iCalendar о событии и публикации рабочего времени человека. Сайты мероприятий в Интернете часто встраивают данные iCalendar в свои веб-страницы с помощью протокола hCalendar , представления iCalendar 1: 1, но написанного в XHTML .
Резюме
- 1 Основные характеристики
- 2 Основной объект
- 2.1 События (VEVENT)
- 2.2 Задачи (VTODO)
- 2.3 Запись в журнале (VJOURNAL)
- 2.4 Свободное / занятое время (VFREEBUSY)
- 2.5 Другие компоненты
- 2.6 Обмен данными с iCalendar
Основные характеристики
Спецификация iCalendar является результатом работы Рабочей группы по календарю и планированию Internet Engineering Task Force (под председательством Аника Гангли из Open Text Inc. ) и была написана Фрэнком Доусоном из Lotus Software и Дериком Стенерсоном из Microsoft . Анонсы в значительной степени основывается на недавней спецификации промышленности VCalendar Internet Mail Consortium (IMC). После выпуска iCalendar IMC заявила, что «надеется, что все разработчики vCalendar воспользуются преимуществами этих новых открытых стандартов и сделают свое программное обеспечение совместимым с vCalendar 1.0 и iCalendar. «
Данные ICalendar имеют текст / календарь типа MIME . Расширение « .ics » используется для обозначения файла, содержащего произвольный набор календаря или информации о расписании, совместимый с этим типом содержимого MIME. Расширение файла «.ifb» используется для обозначения файла, который содержит информацию о доступности, совместимую с этим типом MIME. Тип файла «iCal» предназначен для операционных систем Apple Macintosh для обозначения файла, содержащего информацию о дате и расписании. Тип файла «iFBf» используется в операционных системах Apple Macintosh для обозначения файла, который содержит информацию о свободном / занятом времени.
Набор символов, используемый для всех данных, не определяется самим форматом, но при отсутствии указания на обратное (транспортным протоколом или хранится в виде метаданных файловой системой), l Все данные объекта iCalendar (включая синтаксис его представления) закодирован в UTF-8 .
Используемый формат аналогичен формату заголовка MIME (используется протоколом SMTP для электронной почты или протоколом HTTP и многими производными протоколами), но с некоторыми отличиями. Как и в случае с кодировкой MIME, каждое свойство указывается в отдельной строке, начиная с идентификатора (состоящего из букв, цифр или знаков «-»). Строки, начинающиеся с пробела, образуют продолжение свойства, начатого на предыдущей строке (пробелы в начале строки и предыдущий разрыв строки игнорируются); это продолжение строк обычно накладывается, потому что формат устанавливает максимальную длину 75 символов на строку (не включая управляющие символы в конце строки). Обычно нет пустых строк, пробелы в конце строки не имеют значения, как и пробелы, следующие за другим пробелом.
Каждое свойство состоит из имени, двоеточия и значения по порядку (или нескольких значений, разделенных запятыми, в незначительном порядке). Иногда он может включать один или несколько необязательных параметров (позволяющих более точно интерпретировать данное значение или указать, как оно кодируется, если оно не является текстом, или предоставить альтернативное представление, возможно внешнее, путем ссылки на URI) как «Параметр = значение», разделенное между ними и названием свойства точкой с запятой; если значение параметра включает запятую, точку с запятой или двоеточие (например, URI), оно должно быть заключено в «типизированные двойные кавычки»).
Некоторые свойства определены с типом, который устанавливает стандартный формат для их значений, включая даты и URI. Когда тип свойства допускает несколько значений в неопределенном количестве, они разделяются запятыми (в произвольном порядке): это эквивалентно добавлению другого отдельного одноименного свойства для каждого значения.
Свойства обычно неупорядочены, но, в отличие от MIME, их можно более точно структурировать по подсвойствам,
- либо когда значения вспомогательных свойств находятся в конечном числе и в порядке, предопределенном их типом, путем разделения этих вспомогательных значений точкой с запятой для формирования единого значения;
- или окружая их псевдосвойствами «BEGIN» и «END» (использование которых обязательно для включения всех свойств, определяющих объект iCalendar), чтобы сформировать законченный объект, который может быть включен среди свойств iCalendar объект. другой объект.
Значения свойств также могут быть явно типизированы (в противном случае их тип по умолчанию — текстовый) и закодированы, если текстового представления недостаточно (например, для двоичных данных), с использованием параметров после имени свойства.
Основной объект
Объект верхнего уровня в iCalendar — это «Основной объект календаря и планирования». Это сборник информации по календарю и расписанию. Обычно эта информация состоит из одного объекта iCalendar. Однако несколько объектов типа iCalendar могут быть последовательно сгруппированы вместе. Первая строка должна быть «BEGIN: VCALENDAR», а последняя строка должна быть «END: VCALENDAR»; содержимое между этими двумя строками называется «icalbody». Тело объекта iCalendar состоит из набора свойств календаря и одного или нескольких компонентов календаря. Свойства календаря — это атрибуты, которые применяются ко всему календарю. Компоненты календаря — это набор свойств, которые следуют определенному синтаксису. Например, компонент может указать событие, задачу, запись в журнале, информацию о часовом поясе, свободный или занятый временной интервал или даже сигнал тревоги.
Вот простой пример (из RFC 2445) объекта iCalendar, который определяет событие Дня взятия Бастилии, которое происходит из 14 июля 1997 г. в 17:00 по всемирному координированному времени в 15 июля 1997 г. в 03:59 UTC:
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//hacksw/handcal//NONSGML v1.0//EN BEGIN:VEVENT DTSTART:19970714T170000Z DTEND:19970715T035900Z SUMMARY:Fête à la Bastille END:VEVENT END:VCALENDAR
В стандарте определены различные типы компонентов. Они описаны ниже.
События (ВЕВЕНТ)
Компонент «VEVENT» предлагает панель свойств, описывающих событие как запланированное количество времени в календаре. Обычно это время занято действительным событием, но его можно настроить в «прозрачном» режиме, чтобы изменить эту интерпретацию.
Классические свойства компонента VEVENT:
- DTSTART: Дата начала мероприятия
- DTEND: дата окончания мероприятия
- РЕЗЮМЕ: Название мероприятия
- МЕСТО: Место проведения мероприятия
- КАТЕГОРИИ: Категория мероприятия (например: Конференция, Вечеринка . )
- Статус: Статус события ( ПРЕДВАРИТЕЛЬНОЕ , ПОДТВЕРДИЛ , ОТМЕНЕН )
- ОПИСАНИЕ: Описание события.
- TRANSP: определяет, становится ли ресурс, назначенный событию, недоступным (OPAQUE, TRANSPARENT)
- ПОСЛЕДОВАТЕЛЬНОСТЬ: количество обновлений, первое обновление — 1
Компонент VEVENT может содержать компонент VALARM для определения сигналов тревоги. Такие события имеют свойство DTSTART, которое определяет дату и время начала, и свойство DTEND, которое определяет дату и время окончания. Если событие периодическое, DTSTART определяет начало первого события.
Периодические события без определенного времени, такие как дни рождения или периодические напоминания, также представлены с помощью VEVENT. Эти события должны иметь значение типа DATE для свойства DTSTART вместо типа DATE-TIME по умолчанию и не должны включать свойство «DTEND».
Задачи (VTODO)
Компонент «VTODO» описывает объект «сделать», то есть объект действия или задачу.
Ниже приведен пример списка дел с крайним сроком 15 апреля 1998 г. , согласно RFC 2445. Звуковой сигнал был определен для уведомления пользователя календаря в полдень за день до выполнения задачи. Тревога повторится еще 4 раза с интервалом в один час. Определение «to-do» менялось дважды с момента его первоначального создания.
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//ABC Corporation//NONSGML My Product//EN BEGIN:VTODO DTSTAMP:19980130T134500Z SEQUENCE:2 UID:uid4@host1.com ORGANIZER:MAILTO:unclesam@us.gov ATTENDEE;PARTSTAT=ACCEPTED:MAILTO:jqpublic@host.com DUE:19980415T235959 STATUS:NEEDS-ACTION SUMMARY:Submit Income Taxes BEGIN:VALARM ACTION:AUDIO TRIGGER:19980414T120000 ATTACH;FMTTYPE=audio/basic:http://host.com/pub/audio-files/ssbanner.aud REPEAT:4 DURATION:PT1H END:VALARM END:VTODO END:VCALENDAR
Запись в журнале (VJOURNAL)
Компонент VJOURNAL описывает запись журнала. Он просто связывает описательный текст с определенной датой и может использоваться для записи ежедневной активности или выполнения задачи. Компонент «VJOURNAL» не занимает время, поэтому он не влияет на свободное или занятое время (как входы «TRANSPARENT»). На практике только несколько реализаций формата iCalendar поддерживают записи «VJOURNAL».
Следующий пример представляет собой запись журнала в соответствии с RFC 2445:
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//ABC Corporation//NONSGML My Product//EN BEGIN:VJOURNAL DTSTAMP:19970324T120000Z UID:uid5@host1.com ORGANIZER:MAILTO:jsmith@host.com STATUS:DRAFT CLASS:PUBLIC CATEGORY:Project Report, XYZ, Weekly Meeting DESCRIPTION:Project xyz Review Meeting Minutes\n Agenda\n1. Review of project version 1.0 requirements.\n2. Definition of project processes.\n3. Review of project schedule.\n Participants: John Smith, Jane Doe, Jim Dandy\n-It was decided that the requirements need to be signed off by product marketing.\n-Project processes were accepted.\n -Project schedule needs to account for scheduled holidays and employee vacation time. Check with HR for specific dates.\n-New schedule will be distributed by Friday.\n- Next weeks meeting is cancelled. No meeting until 3/23. END:VJOURNAL END:VCALENDAR
Свободное / занятое время (VFREEBUSY)
Компонент «VFREEBUSY», определенный в RFC 2445, описывает либо запрос времени занятости, либо ответ на запрос, либо публикует набор значений времени занятости. Ниже приведен пример публикации времени занятости в соответствии с RFC 2445. Объект iCalendar должен быть размещен по определенному URL-адресу с расширением «.ifb»:
BEGIN:VCALENDAR VERSION:2.0 PRODID:-//RDU Software//NONSGML HandCal//EN BEGIN:VFREEBUSY ORGANIZER:MAILTO:jsmith@host.com DTSTART:19980313T141711Z DTEND:19980410T141711Z FREEBUSY:19980314T233000Z/19980315T003000Z FREEBUSY:19980316T153000Z/19980316T163000Z FREEBUSY:19980318T030000Z/19980318T040000Z URL:http://www.host.com/calendar/busytime/jsmith.ifb END:VFREEBUSY END:VCALENDAR
Остальные компоненты
Другие компоненты, определенные в стандарте, — это «VTIMEZONE» (для определения часовых поясов) и «VALARM» (для определения сигналов тревоги). Мы можем заметить, что некоторые компоненты включают в себя другие компоненты («VALARM» часто включается в другие компоненты), и что некоторые компоненты определены для управления другими компонентами, определенными после них («VTIMEZONE» часто используется таким образом.).
Обмен данными с iCalendar
Формат iCalendar разработан для описания данных календаря (например, событий) и намеренно не описывает, что делать с «классическими» данными (текстами и т. Д.).
Сопутствующий компонент, «iCalendar, независимая от транспорта» (iTIP) ( RFC 2446), определяет протокол для обмена объектами iCalendar с целью группирования информации календаря и планирования между «пользователями календаря» (CU); тот, кто начинает обмен данными, берет на себя роль «организатора». Этот стандарт определяет такие методы, как PUBLISH, REQUEST, REPLY, ADD, CANCEL, REFRESH, COUNTER (для согласования изменения записи) и DECLINE-COUNTER (для отклонения встречного предложения).
Другой компаньон, «Протокол взаимодействия на основе сообщений iCalendar (IMIP)» ( RFC 2447), определяет стандартную методологию для реализации iTIP в транспортном протоколе, таком как электронная почта.
«Руководство по Интернет-календарю» ( RFC 3283) описывает взаимосвязь между iCalendar и различными родственными стандартами (настоящими и будущими).
Формат iCalendar был разработан для обеспечения взаимодействия данных календаря; в то время как функции, наиболее часто используемые пользователями, широко поддерживаются реализациями iCalendar и могут обмениваться данными, операции между реализациями более продвинутых функций «хромают».
Протокол доступа к календарю ( RFC 4324) обеспечивает универсальный метод реализации календаря в реальном времени.
Рабочая группа IETF по календарю и планированию (calsch) в прошлом работала над различными расширениями и протоколами совместимости для iCalendar. Рабочая группа официально прекратила свое существование как рабочая группа IETF в Сентябрь 2004 г. , но его список рассылки по-прежнему используется для обсуждений на календарную тему.
Смотрите также
Внешние ссылки
- Спецификация основного объекта Интернет-календаря и планирования (iCalendar) — RFC 2445 — IETF. Ноябрь 1998
- Калифорнийский университет в Беркли, 28-30 июля 2004 г. Тестирование совместимости с Calconnect IV RFC 2445, RFC 2446 и RFC 2447
- Документ iCalendar DTD (xCal)
- Французский перевод RFC 2445
Рекомендации
- ↑ (в) Запрос на комментарии п O 5545 .
- ↑ абгрд и е (о) Запрос на комментарии п о 2445 .
- ↑ (в) Запрос на комментарии п O 2446 .
- ↑ (в) Запрос на комментарии п O 2447 .
- ↑ (в) Запрос на комментарии п O 3283 .
- ↑ (в) Запрос на комментарии п O 4324 .
- ↑[1]
- ↑[2]
Icalendar что это
What’s on this Page
.ICS вариант №
Спецификация основных объектов календаря и планирования Интернета (iCalendar) — это интернет-стандарт (RFC 2445) для обмена и развертывания событий календаря и планирования. Формат iCalendar является интероперабельным, что обеспечивает обмен информацией календаря между пользователями, использующими различные приложения электронной почты. iCalendar форматирует входные данные как многоцелевые расширения почты Интернета (MIME) и облегчает обмен объектами через различные транспортные протоколы. Эти транспортные протоколы могут быть SMTP, HTTP, двухточечной асинхронной связью и сетевым транспортом на основе физических носителей.
iCalendar позволяет пользователям обмениваться событиями, задачами, зависящими от даты/времени, и информацией о занятости по электронной почте другим пользователям, которые могут ответить. Файлы iCalendar хранятся с использованием суффиксов «.ics», «.iCalendar» или «.ifb» с типом MIME «текст/календарь». iCalendar остается самодостаточным без какой-либо зависимости от транспортного протокола. Веб-серверы (с протоколом HTTP) могут передавать информацию iCalendar, а веб-страницы могут содержать данные iCalendar во встроенной форме с использованием iCalendar.
Краткая история формата файлов ICS
В 1998 году Инженерная рабочая группа Интернета (IETF) определила iCalendar как стандарт (RFC 2445). Стандарт был задокументирован Фрэнком Доусоном (Lotus Notes Corporation) и Дериком Стенерсоном (Microsoft). В 2009 году стандарт был снова усовершенствован Бернаром Десруиссо (Oracle) как RFC 5545. На этот раз были добавлены некоторые новые функции, а некоторые устаревшие функции объявлены устаревшими. В 2016 году был выпущен RFC 7986, дополненный оригинальным RFC iCalendar. RFC 7986 добавил новые характеристики к основному объекту VCALENDAR, а также были введены новые вспомогательные функции для систем конференц-связи.
Формат файла ICS
Тип MIME, используемый данными iCalendar, — «текст/календарь». Набор символов по умолчанию для iCalendar — UTF-8, однако, указав параметры в MIME, можно использовать другой набор символов. Файл iCalendar содержит разделы, среди которых «VCALENDAR» является глобальным разделом, который инкапсулирует все остальные разделы. Раздел VEVENT определяет события, VTODO перечисляет все элементы списка дел, VJOURNAL содержит записи журнала, а VTIMEZONE указывает информацию о часовом поясе. разрешено несколько разделов аналогичной категории. Для многочисленных событий в файле iCalendar может присутствовать несколько разделов VEVENT.
Строки содержимого
Объекты iCalendar организованы в отдельные строки текста «строки содержимого». В этом формате файла последовательность CRLF завершает строку, тогда как длина строки ограничена 75 октетами, не считая разрыва строки. Длинный элемент данных может быть разделен на несколько строк.
Разделители списков и полей
Свойства и параметры задают список значений, разделенных запятой. Строки в кавычках используются для значений параметров на основе URI. Список параметров может быть построен по значению свойства. Каждый параметр свойства в этом списке должен быть разделен точкой с запятой.
В списке значений точка с запятой изолирует параметры свойств, а запятая — отдельные значения свойств. Пример приведен ниже:
ATTENDEE;RSVP#TRUE;ROLE#REQ- contestant:mailto: name@example.com DATE;VALUE#DATE:20170304,20180504,2015704,201270904Несколько значений
Некоторые свойства могут иметь несколько значений. Простое создание новой строки содержимого с именем свойства является основным правилом для многозначных свойств. Однако для одного значения с несколькими языковыми вариантами нельзя использовать многозначные свойства.
Двоичный контент
В объекте iCalendar значение свойства может ссылаться на данные двоичного содержимого, помещенные во внешний объект MIME с использованием URI. Встроенное двоичное содержимое можно использовать в особых ситуациях с параметром «ENCODING», когда приложению необходимо выразить объект iCalendar как единую сущность. В следующем примере объясняется свойство «ATTACH» со ссылкой на URI:
Набор символов
Хотя схема кодировки по умолчанию для iCalendar — UTF-8, параметр свойства не указан для определения кодировки значения свойства. в передачах MIME параметр “charset” ДОЛЖЕН использоваться для существующей кодировки.
использованная литература
- Спецификация основных объектов Интернет-календаря и планирования
- iCalendar (RFC 5545)
- iCalendar
Icalendar что это
Используйте DeepL Переводчик для мгновенного перевода текстов и документов
Попробуйте DeepL Переводчик
- Перевод в процессе набора текста
- Высочайшее в мире качество
- Перемещение документов
Переводите прямо сейчас
Непроверенные источники (русск → английск) (RU → EN)
Any event or a whole calendar can be exported to file of the *.ics format. iCalendar is a file format for storing calendars of events.
teamwox.com
Любое мероприятие календаря или календарь целиком может быть экспортирован в файле формата *.ics. iCalendar — это формат файлов для хранения календаря мероприятий.
teamwox.com
The feature of importing of events from *.ics files is implemented in the
[. ] Calendar module. iCalendar is a file format [. ]
for storing calendars of events.
teamwox.com
В модуле «Календарь» реализована функция импорта
[. ] мероприятий из файлов *.ics. iCalendar — это формат [. ]
файлов для хранения календаря мероприятий.
teamwox.com
Gem ice_cube allows to specify multiple rules
and dates for repeated events
[. ] using its API similar to iCalendar, and serialize/deserialize [. ]
schedules to/from YAML and Ruby Hash formats.
inexfinance.com
Gem ice_cube позволяет задавать
правила для повторяющихся событий
[. ] используя API на подобие iCalendar и сериали зовать/десериализовать [. ]
расписания в форматах YAML и Ruby Hash.
Что такое расширение файла ICALENDAR?
У нас есть четыре существующие программные обеспечения, связанные с файлами ICALENDAR (как правило это программное обеспечение от Microsoft Corporation, известное как Microsoft Outlook), и их можно отнести к категории основных типов файлов один. Традиционно эти файлы имеют формат iCalendar File . Чаще всего файлы ICALENDAR классифицируют, как Uncommon Files.
Файлы с расширением ICALENDAR были идентифицированы на настольных компьютерах (и некоторых мобильных устройствах). Они полностью или частично поддерживаются Windows, Mac и iOS. Рейтинг популярности данных файлов составляет «Низкий» и они обычно не используются.
Если у вас возникли проблемы с открытием файлов ICALENDAR, или если вы просто хотите узнать больше о связанных с ними программах и разработчиках см. полную информацию, представленную ниже.
