Порты для работы мессенджеров Telegram, WhatsApp, Skype, Viber
Telegram: Использует входящие TCP порты 443, 80, 88 и 84431.
WhatsApp: Использует входящие TCP порты 443, 80, 88 и 84431
Skype: Использует входящие TCP порты 80 и 4433.
Viber использует следующие порты для своей работы:
Входящее TCP: 58470, 58521, 58525, 58554, 45112, 58620, 62122, 62577, 62899, 62934
Исходящие TCP: 58470, 443, 58525, 80, 58554, 58620, 4244, 61902, 62093, 62122, 62577, 62899, 62934 и 52421
Входящее UDP: 53531
Исходящее UDP: 45122 и 105751
Зачем столько Viberу портов не понятно)
Занятная приоритизация голосового трафика в Telegram
Наверное, многим интересно, как же команде Telegram удалось сделать популярную для мессенджеров функцию голосовых звонков уже сразу после запуска разительно отличающейся по качеству в лучшую сторону перед многими другими VoIP — сервисами.
Во время изучения работы Telegram Calls я обратил внимание на интересную техническую деталь, которая используется на сетевом уровне и помогает уменьшить задержки при прохождении пакетов, когда при соединении используются релейные сервера.
Если взглянуть на дамп трафика, который проходит при звонке, в котором использовался релейный сервер, можно заметить, что трафик определяется протоколом RIP. IP на 91. — это сервер Telegram. Я снимал дамп трафика на своём VPN — сервере, поэтому адрес клиента из локальной подсети.

А вот скриншот из дебага клиента, но уже при P2P. Стоит отметить, что 520 порт назначен только серверам, поэтому этот метод работает тогда, когда P2P — соединение между клиентами невозможно и один из серверов из списка выступает в роли релея.

Вспомним, что нам известно про протокол RIP?
RIP — протокол маршрутизации. RIP работает на 3 уровне (сетевой) стека TCP/IP, используя UDP порт 520. UDP, то есть доставка, не требующая подтверждения приёма, как известно, сам по себе отлично подходит для трафика реального времени, коим является голос.
Протоколы маршрутизации нужны, чтобы маршрутизаторы могли быстро обмениваться служебной информацией о присоединённых к ним и их соседям сетям. Обновления информации о маршрутах критически важны для быстрого восстановления работы сети при изменениях в ней, поэтому многие производители сетевого оборудования присваивают трафику протоколов маршрутизации максимальный приоритет обработки. То есть пропускают его впереди всего остального трафика.
Эта приоретизация реализуется в маршрутизаторах с помощью DSCP — кодов ( Differentiated Services Code Point ), и по-умолчанию, например, в Cisco согласно RFC 791 и RFC 2474 протоколы маршрутизации RIP/RIP2/OSPF/EIGRP маркируются кодом 6. А это, на минуточку, предвысший, Internetwork Control приоритет.

Кроме приоритизации DSCP, Cisco IOS также имеет внутренний механизм PAK_priority, который служит для предоставления приоритета для важных датаграмм именно в момент их прохождения через роутер. PAK_priority designation был задуман разработчиками Cisco (и, можно предположить, некоторыми другими) оборудования как критически важный для корректной работы Cisco IOS, и поэтому его никак нельзя конфигурировать. Что исключает возможность администраторам как-либо влиять на приоритетный пропуск трафика, имеющего для системы характеристики Control.
Похоже, вспомнив про древний протокол и особенности его работы (полезный UDP, существование возможности Unicast — обмена), архитекторы Telegram использовали его порт, тем самым заставили многие маршрутизаторы на пути следования пакетов обрабатывать их трафик как очень важный, тем самым, очевидно, несколько сократив задержки.
Вроде бы небольшая деталь в мире мощных кодеков, но, как говорится, дьявол кроется в мелочах — так почему бы не заставить эти мелочи работать на благо конечной цели?
- IT-инфраструктура
- Cisco
- Сетевые технологии
Поиск TCP/UDP Портов
TCP-порт 2279 использует протокол управления передачей данных (TCP), который является одним из основных протоколов в сетях TCP/IP. TCP является протоколом с установлением соединения и требует квитирования для установки сквозной связи. Только после установления соединения пользовательские данные могут пересылаться в обоих направлениях.
Внимание! TCP гарантирует доставку пакетов данных через порт 2279 в том же порядке, в котором они были отправлены. Гарантированная связь через TCP-порт 2279 является основным отличием TCP от UDP.
Предоставляемые через UDP-порт 2279 UDP услуги не отличаются надежностью, так как датаграммы могут быть получены в сдублированном виде, с нарушенной очередностью или даже могут пропасть без какого-либо предупреждения. UDP на порт 2279 проверка и исправление ошибок не являются обязательными или должны выполняться в прикладной программе, что позволяет избежать накладных расходов на такую обработку на уровне сетевого интерфейса.
UDP (User Datagram Protocol) является минимальным ориентированным на работу с сообщениями протоколом транспортного уровня (протокол описан в IETF RFC 768). Примеры прикладных программ, часто использующих UDP: передача голоса по IP-протоколу (VoIP), передача мультимедийных потоков и многопользовательские игры в режиме реального времени. Множество веб-приложений используют UDP, к примеру, система доменных имен (DNS), информационный протокол маршрутизации (RIP), протокол динамической конфигурации хостов (DHCP), простой протокол управления сетью (SNMP).
TCP против UDP – TCP: надежный, упорядоченный, тяжеловесный, потоковый; UDP – ненадежный, неупорядоченный, легковесный, датаграммы.
Порты TCP и UDP, используемые программными продуктами Apple
Узнайте больше о портах TCP и UDP, используемых продуктами Apple, такими как macOS и iCloud. Многие из этих портов являются распространенными стандартными портами.
Порты, используемые продуктами Apple
Здесь приведен не полный перечень портов, а краткое справочное руководство с самыми распространенными примерами. Это руководство периодически обновляется информацией, доступной на момент публикации. Если хосты и порты предназначены для корпоративных сетей, узнайте об использовании продуктов Apple в корпоративных сетях.
Некоторое ПО может использовать другие порты и службы, поэтому при настройке брандмауэра и похожих систем управления доступом может понадобиться ПО для наблюдения за портами.
Некоторые службы могут использовать более одного из этих портов. Например, служба VPN может использовать до четырех различных портов. После нахождения продукта в списке выполните поиск (Command-F) в браузере по этому имени, а затем повторите поиск (Command-G), чтобы найти все упоминания данного продукта.
Некоторые брандмауэры позволяют выборочно настраивать порты UDP или TCP с одинаковым номером, поэтому важно знать тип настраиваемого порта. Если в брандмауэре не предусмотрено указание типа порта, вероятнее всего, изменение одного порта может повлиять на другой.
«Почта» (отправка почты); «Почта iCloud» (отправка почты)
1. Служба зарегистрирована организацией Internet Assigned Numbers Authority, за исключением случаев с пометкой «использование не зарегистрировано».
2. Количество документов RFC (Request For Comment), описывающих службу или протокол. Документы RFC утверждаются компанией RFC Editor.
FaceTime доступен не во всех странах и регионах.
Дополнительная информация
Брандмауэр для программ в macOS не является брандмауэром на основе портов. Он управляет доступом отдельных программ, а не доступом к портам.
Информация о продуктах, произведенных не компанией Apple, или о независимых веб-сайтах, неподконтрольных и не тестируемых компанией Apple, не носит рекомендательного или одобрительного характера. Компания Apple не несет никакой ответственности за выбор, функциональность и использование веб-сайтов или продукции сторонних производителей. Компания Apple также не несет ответственности за точность или достоверность данных, размещенных на веб-сайтах сторонних производителей. Обратитесь к поставщику за дополнительной информацией.
